Pentaho Reporting 3.8.1-RC1 released

On Friday without much ado, Pentaho uploaded the Release Candidate 1 of Pentaho Reporting 3.8.1 to the Sourceforge servers. This bug-fix release contains only bug-fixes, among the more noteworthy we have PRD-3349 and PRD-3375 (Numbers rounded wrongly) and some changes to the parameter handling so that cascading prompts get more usable inside the report designer and the Pentaho BI-Server.

Full list of all cases closed in this release

Download: Download Pentaho Report Designer 3.8.1-RC1

This entry was posted in Release on by .

About Thomas

After working as all-hands guy and lead developer on Pentaho Reporting for over an decade, I have learned a thing or two about report generation, layouting and general BI practices. I have witnessed the remarkable growth of Pentaho Reporting from a small niche product to a enterprise class Business Intelligence product. This blog documents my own perspective on Pentaho Reporting's development process and our our steps towards upcoming releases.

6 thoughts on “Pentaho Reporting 3.8.1-RC1 released

  1. Dave Neary

    I just downloaded & installed PRD 3.8.1 RC1, and saved a tiny change to a report I had created with PRD CE 3.8.0 (in “About…” it lists the version as “3.7.0-GA.12964”).

    The resulting .prpt file gives a parse error on the server, and opening it in the old PRD crashes Xorg on me.

    Were there any changes in the file format between the two versions? And how can I update my server to handle these new .prpt files? Is there a recommended upgrade procedure?


  2. Thomas Morgner

    A newer report designer does not work with older servers for the reasons outlined in

    Upgrade your server to the latest release candidate (3.9.0-RC1) if you want to use the latest release candidate of the report designer.

    Opening a old file in the report designer should never crash your X-Server. If it does then this indicates a error in the server more than anything else. After all, we are just a poor standard Java application. File me a JIRA case on the crash with enough information to replicate the crash (Linux version, whether 3D desktop or similar features is enabled, etc) then we might be able to work around the crash until the X-Server gets fixed by the maintainer.

  3. Dave Neary

    I just upgraded to BI server 3.8.0 – not recent enough?

    It actually was PRD 3.7.0 before, I had unzipped 3.8.0 on top of 3.7.0 (which doesn’t do anything any good, obviously!)


  4. Dave Neary

    Thanks Thomas!

    It seems like you don’t have to save everything in a .prpt file, just the things that the report designer changes – in which case, the report would only stop working if you used the new feature.

    I like your horse/petrol analogy, but I think it’s more like “My old car can’t run on unleaded, can I still buy petrol for it?” If I filled up my car with petrol & the motor broke, and the garage owner told me afterwards that it was my fault because it was new petrol, I wouldn’t be happy.


  5. Thomas Morgner

    No, the 3.8.1-rc reporting engine matches the 3.9-rc BI-Server.

    Some changes do not affect the backward compatibility, but some are always a killer.

    * Charting changes are among the worst, and this release has seen quite a few fixes there.
    * followed by: any other expression/function changes
    * then style changes (although they are seldom these days, and only if there is a formula or expression added to the newly introduced style-key)

    And yes, unzipping does not get rid of old jars in the lib directory, and thus you run with a wild mix of old and new jars – never a good idea. Old C/C++ programmers may know this as DLL-hell.

  6. Dave Neary

    Java programmers call it classpath hell 🙂 When two versioned .jar files contain the same API, it’s hard to tell which one will actually be used.

Comments are closed.